Web lists-archives.com

Re: [glib] Android port




It's been discussed [1] recently on this list that there are
probably some legal issues which make using glib2 on Android
difficult or impossible. While this does not answer your question
directly it may explain the reasons why glib2 port to Android
does not draw much developers' attention and indeed there may
be bugs in newer versions. On the other hand, if you spot a problem
with the Android port you are probably welcome to fix it.

Regards,

Rafal

[1] https://mail.gnome.org/archives/gtk-list/2016-July/msg00028.html


10.08.2016 23:16 "Brown, Matthew" <Matthew.Brown@xxxxxxxxxx> wrote:
>
>
> I have a project running on various Linux environments which I need to port to
> Android. This project depends on glib 2.32 or newer and will need to run on at
> least Android API 19. I've attempted to build from the latest stable source
> and hit well-known compile errors related to the bionic c library.
>
> I've been searching the archive and more generally on the 'net for some help,
> but I'm not finding anything but notes regarding versions older than 2.32.
>
> Am I just overlooking something? I find it hard to believe that no one has
> ported a more recent glib version to Android, but I haven't located such an
> effort.
>
> Any pointers are appreciated. Thanks!
>
> -- Matt
> _______________________________________________
> gtk-list mailing list
> gtk-list@xxxxxxxxx
> https://mail.gnome.org/mailman/listinfo/gtk-list
_______________________________________________
gtk-list mailing list
gtk-list@xxxxxxxxx
https://mail.gnome.org/mailman/listinfo/gtk-list