Web lists-archives.com

Re: Desktop as transient window




On Mon, 10 Aug 2015 12:17:58 -0500
richard boaz <ivor.boaz@xxxxxxxxx> wrote:
> hi,
> 
> i think this is a case when the warning, (which can be ignored), is
> meant for the developer, and not the end-user.
> 
> i would trap the error, ignore it, and definitely not forward to the
> end-user; following the dictum "avoid confusing them as much as
> possible..."

You can use the not-often-heard-about GDK_VERSION_MIN_REQUIRED macro to
get rid of these deprecation warnings if you want.  You can then either
define it or not at compile time (say when in debug mode) to decide
whether you want to receive a chronicle of what is not going to work in
gtk+-4.

For example this:

#define GDK_VERSION_MIN_REQUIRED GDK_VERSION_3_0

will silence warnings about anything deprecated after gtk-3.0.0 came
out.  Generally you should set the macro to the minimum gtk+ version
that you require for the project in question.

Chris
_______________________________________________
gtk-list mailing list
gtk-list@xxxxxxxxx
https://mail.gnome.org/mailman/listinfo/gtk-list