Web lists-archives.com

Building with a locally build glib




I am on Debian Jessie and it has system glib-2.42.1 and locally built is glib-2.45.1.

Despite significant jocking around the relevant paths to point to glib-2.45.1 I continue to receive at build:

checking for GLIB - version >= 2.28.0...
*** 'pkg-config --modversion glib-2.0' returned 2.42.1, but GLIB (2.45.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.28.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.


I can't easily remove the system version and I have changed symlinks in the /lib and /usr/lib to point the newer version and the above error continues.

Hoping for someone to show me what I am missing.

Nicky



 
_______________________________________________
gtk-list mailing list
gtk-list@xxxxxxxxx
https://mail.gnome.org/mailman/listinfo/gtk-list