Web lists-archives.com

Re: GitLab CI runners for non-Linux systems




On Fri, May 18, 2018 at 10:15 PM <xclaesse@xxxxxxxxx> wrote:
Thanks for this call for help, it's our chance to finally be serious
about supporting multiple platforms, instead of always fixing a
posteriori. Thanks to gitlab that shouldn't be too hard to setup.

Le vendredi 18 mai 2018 à 10:52 +0100, Philip Withnall a écrit :
>  • macOS (ideally several versions, since we support from OS X 10.7
> upwards[2])

I did a quick test on a macmini (macOS 10.13.4) we have in Collabora
office, and it's almost too easy to setup, not even a challenge!

Well... except that glib fails to build with meson because libffi
subproject does not support darwin. I'll try to investigate that.

I've been building http://mirrors.kernel.org/sources.redhat.com/libffi/libffi-3.2.1.tar.gz on macOS with no problems since at least 10.9. I think maybe just the meson fork (https://github.com/centricular/libffi/commits/meson) of libffi has this problem.

You could try pre-installing libffi from the tarball on the image, then it wouldn't use the wrapped subproject, I think?

Regards,
Philip C
_______________________________________________
gtk-devel-list mailing list
gtk-devel-list@xxxxxxxxx
https://mail.gnome.org/mailman/listinfo/gtk-devel-list