Web lists-archives.com

Re: Generating glib-genmarshal




On 7 September 2017 at 16:35, John Emmas <john@xxxxxxxxxxxxxxxxxx> wrote:

> gdk-pixbuf and gdk+2 both built fine for me.  The only odd thing I noticed
> was when building gtk (from gtk-2-24) I saw quite a few warning messages
> looking like this:-
>
>       WARNING: The token "BOOL" is deprecated; use "BOOLEAN" instead
>       WARNING: The token "NONE" is deprecated; use "VOID" instead
>
> They're probably nothing to worry about (I think they might be coming from
> 'gtk/gtkmarshal.list').  In fact it's possible they've always been there but
> I don't remember noticing them before...

No, the deprecation warnings are new, and were added with the rewrite to Python.

The `BOOL` and `NONE` keywords have been deprecated for 17 years —
they were deprecated when glib-genmarshal was added to the GLib
repository. Older versions of GTK+ still use those keywords because
they haven't been touched in years, and people cargo-culted their way
out of these things.

The deprecation warnings are there to let people know that
copy-pasting from old projects does not imply that things will never
change. :-)

Ciao,
 Emmanuele.

-- 
https://www.bassi.io
[@] ebassi [@gmail.com]
_______________________________________________
gtk-devel-list mailing list
gtk-devel-list@xxxxxxxxx
https://mail.gnome.org/mailman/listinfo/gtk-devel-list