Web lists-archives.com

Re: Generating glib-genmarshal




In GLib 2.52, glib-genmarshal is a C program. In GLib master, which
will become GLib 2.54 soon, glib-genmarshal is a Python program.

The change from C to Python will *not* be backported to GLib 2.52.

Ciao,
 Emmanuele.


On 6 September 2017 at 16:41, John Emmas <john@xxxxxxxxxxxxxxxxxx> wrote:
> Hi guys...
>
>       python  win32/gen_util_scripts.py --type=glib-genmarshal
> --version=<WHATEVER>
>
> If I'm building glib from git master, the above command works fine (if I
> issue it from a DOS window or from my MSVC project file). However... it
> produces an error if I try to build from the 'glib-2-52' branch.  Is that to
> be expected?
>
> In case it helps, the error message that I see is:-
>
>         File "win32/gen_util_scripts.py", line 30, in main
>            raise ValueError('Type must be glib-mkenums or gdbus-codegen')
>
> It's probably something that's been changed in 2-52 but not merged into
> master yet.  Anyway... just flagging it up,
>
> Thanks, John
> _______________________________________________
> gtk-devel-list mailing list
> gtk-devel-list@xxxxxxxxx
> https://mail.gnome.org/mailman/listinfo/gtk-devel-list



-- 
https://www.bassi.io
[@] ebassi [@gmail.com]
_______________________________________________
gtk-devel-list mailing list
gtk-devel-list@xxxxxxxxx
https://mail.gnome.org/mailman/listinfo/gtk-devel-list