Web lists-archives.com

Glib-2 2.46.2 unittest regex fails




Hi All,

I am using Yocto poky Distro version 1.8.1 to build my image.
And have used Glib-2 version 2.46.2 package.

While testing glib-2 unittests, one of the test case "glib/regex.test" failed with below logs:

# ERROR:../../../glib-2.46.2/glib/tests/regex.c:129:test_new_fail: assertion failed (error == (g-regex-error-quark, 142)): Error while compiling regular _expression_ (?(?<ab)) at char 3: assertion expected after (?( (g-regex-error-quark, 128)

I wanted to report this issue and at the same time was curious to know the reason.

--
Regards,
Nikita Gupta
_______________________________________________
gtk-devel-list mailing list
gtk-devel-list@xxxxxxxxx
https://mail.gnome.org/mailman/listinfo/gtk-devel-list