Web lists-archives.com

Re: Gtk+4.0




On Wed, 14 Sep 2016 16:12:15 +0100, Davin McCall <davmac@xxxxxxxxxx>
wrote:
> I think removing deprecated API when incrementing the major version is
> acceptable...

That's is what I wonder about. I'm just pedantic and likely misreading
this line:

> When bumping to a new major version deprecated API will be removed.
[1]
https://blog.gtk.org/2016/09/01/versioning-and-long-term-stability-promise-in-gtk/

Wouldn't it be much more convenient to introduce required and projected
API-Breaks at the start of a new development-series e.g. at 3.90 (so now,
during this days?), 4.90 and so on? So especially developers of GNOME and
others which follow the development-series would have an easier life,
because subsequent breaks between 3.90 and 4.00 or 4.0 and 5.0 will less
likely.

Peter
_______________________________________________
gtk-devel-list mailing list
gtk-devel-list@xxxxxxxxx
https://mail.gnome.org/mailman/listinfo/gtk-devel-list