Web lists-archives.com

Re: Reinstate support for OS X versions older than 10.9




On Tue, 2015-09-22 at 18:58 -0500, Ryan Schmidt wrote:
> On Sep 22, 2015, at 6:32 PM, John Ralls wrote:
> 
> > I’m a bit conflicted about this. Yes, 10.9 is a bit new for a
> > cutoff, but on the other hand upgrades to 10.10 are free and run on
> > any machine that can run 10.7
> 
> Per the EveryMac URL I posted, in addition to older PowerPC Macs that
> cannot be upgraded past 10.4, newer PowerPC Macs that cannot be
> upgraded past 10.5, and 32-bit Intel Macs that cannot be upgraded
> past 10.6, there are some 64-bit Intel Macs that cannot be upgraded
> past 10.7.
> 
> Further to that, there are users who do not wish to upgrade their OS,
> even if their machine can support it. They may have any number of
> reasons for that. For example, 10.6 is the last OS that can run
> PowerPC applications on Intel systems; a user may have PowerPC
> software they wish to continue using. Or a user may dislike the
> significant user interface changes Apple made in 10.7 or 10.10.
> 
> 
> > There’s always the option of sticking with the last releases of
> > GLib and Gtk+ if you want to build/run on older machines.
> 
> Considering the options we have in the MacPorts package management
> system, the possibilities I see are as follows:
> 
> - Keep glib2 at version 2.44.1 until all MacPorts users have upgraded
> to OS X 10.9 or later. This will not occur for years if ever. We
> still have MacPorts users today that use OS X 10.4.
> 
> - Upgrade glib2 to version 2.46.0 now, thereby preventing users on OS
> X 10.8 and earlier from using all the software in MacPorts that
> depends in some way on glib2.
> 
> - Add conditional logic to the glib2 port to use 2.46.0 on OS X 10.9
> and later and 2.44.1 on OS X 10.8 and earlier. This might be viable.
> Some other MacPorts ports for other gnome software is already doing
> something like this. But it is more complicated for the port
> maintainer (me) and it might break some use cases. For example, it is
> possible to build *on* 10.9 *for* 10.8; such an attempt might fail
> with 2.46.0.
> 
> - Change glib 2.46.0 so that it can be built without GNotification
> support on older systems. This is what I'm asking for.

I don't think that making new APIs do nothing, or ABI changing between
OSX versions is a good idea. You might want to work on adding support
for another notification sub-system (I don't think that OSX had one
builtin before 10.9, or without the needed feature), such as Growl.
Then make GNotification choose which one to use at run-time.

Depending on what the code ends up looking like, it might be too much
of a burden for upstream to consider it, but at least you have
something you can maintain inside MacPorts.

Cheers

_______________________________________________
gtk-devel-list mailing list
gtk-devel-list@xxxxxxxxx
https://mail.gnome.org/mailman/listinfo/gtk-devel-list