Web lists-archives.com

Re: GIT issue while cloning (fatal: pack is corrupted (SHA1 mismatch)) !!!




On Tue, May 28, 2019 at 06:45:18PM +0000, Vanak, Ibrahim wrote:

> BUT still I have significant slowness(50 times slower than clone on
> linux machine) while cloning. HPUX box is having very good H/W
> configuration and network is also stable.

>From your output:

> [hpux]
> Receiving objects: 100% (63627/63627), 681.90 MiB | 111.00 KiB/s, done.
> [linux]
> Receiving objects: 100% (63627/63627), 681.90 MiB | 5.59 MiB/s, done.

The main things going on there are:

  1. we're getting the bytes over the network

  2. we're computing a sha1 on the stream we're getting

  3. we're zlib inflating any non-delta objects we find and computing
     their sha1

  4. we're checking the filesystem to see if we have other copies of any
     of those objects

For (2) and (3) it could be that the sha1 implementation is not quite as
fast. But 50x is much larger than I'd expect. If you've built Git from
source, you could try running "t/helper/test-sha1 <big-file" and timing
the result. That would isolate sha1 performance.  If it's slow, try
building with "make BLK_SHA1=Yes" or "make OPENSSL_SHA1=Yes" and see if
that's faster.

For (4), we'll have to stat() in .git/objects to see if we have a loose
version of the object. That can be slow if you have a really terrible
NFS setup, for example. But I doubt that would still be slow in v2.21.
There we should be using the new loose-cache which will only readdir()
the object directories once.

If neither of those pan out, it seems like the network is slow? Or maybe
ssh? Or pipes passing data from clone to index-pack?

-Peff