Web lists-archives.com

Bug: subcommand autocomplete fails on 2.21.0




With git 2.21.0, tab completion no longer works for subcommands.

STEPS TO REPRODUCE
1. install git 2.21.0 from https://git-scm.com/download/mac
2. source /usr/local/etc/bash_completion.d/git-extras (manually, or update your .bashrc/.profile and start a new terminal)
2. git clone https://github.com/tj/git-extras
3. cd git-extras
4. sudo make install
5. change directory to a git repository
6. type "git del” and press [tab] 

EXPECTED
line is changed to "git delete-merged-branches"

ACTUAL
[beep]

CONFIG
macOS 10.13.6 (17G5019) and macOS 10.14 (18E226)
git 2.21.0
git-extras 4.8.0-dev

REGRESSION
Works as expected with git 2.17.0.



Paul