Web lists-archives.com

[[PATCH v2] ] INSTALL: add macOS gettext and sdk header explanation to INSTALL




From: out0fmemory <jiu4majia2@xxxxxxx>

* add macOS gettext explanation to get the i18n locale translation take effect in macOS, as the most polular way of gettext
  install in macOS, the gettext is not linked by default, this commit give a tip on this thing.

* add macOS Command Line Tool sdk header explanation to get correct build in macOS 10.14+, as the CLT not install
  the header by default, we need install it by self, this commit give a way to install the loss headers.

Signed-off-by: yanke <jiu4majia2@xxxxxxx>
---
 INSTALL | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/INSTALL b/INSTALL
index c39006e8e7..ed4bd29f8f 100644
--- a/INSTALL
+++ b/INSTALL
@@ -165,6 +165,13 @@ Issues of note:
 	  use English. Under autoconf the configure script will do this
 	  automatically if it can't find libintl on the system.
 
+    In macOS, can install gettext with brew as "brew install gettext"
+    and "brew link --force gettext", the gettext is keg-only so brew not link
+    it to /usr/local by default, so link operation is necessary, or you can
+    follow the brew tips after install gettext. If not link gettext correctly,
+    the git after build will not have correct locale translations, english is the
+    default language.
+
 	- Python version 2.4 or later (but not 3.x, which is not
 	  supported by Perforce) is needed to use the git-p4 interface
 	  to Perforce.
@@ -178,6 +185,19 @@ Issues of note:
    will include them.  Note that config.mak is not distributed;
    the name is reserved for local settings.
 
+  - In macOs 10.14, the Command Line Tool not contains sdk headers as before, so
+    need install Command Line Tool 10.14 and install the headers with command
+    "sudo installer -pkg /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg -target".
+    If not install the sdk headers correctly, git build will get errors blew, factly is
+    is because of this problem.
+
+    ld: archive has no table of contents file 'xdiff/lib.a' for architecture x86_64
+    clang: error: linker command failed with exit code 1 (use -v to see invocation)
+    make: *** [Makefile:2369: git-fast-import] Error 1
+    ld: archive has no table of contents file 'xdiff/lib.a' for architecture x86_64
+    clang: error: linker command failed with exit code 1 (use -v to see invocation)
+    make: *** [Makefile:2046: git] Error 1
+
  - To build and install documentation suite, you need to have
    the asciidoc/xmlto toolchain.  Because not many people are
    inclined to install the tools, the default build target
-- 
2.19.1.1052.gd166e6afe5