Re: [GSoC][PATCH v3 01/13] sequencer: make two functions and an enum from sequencer.c public
- Date: Tue, 10 Jul 2018 10:53:10 -0700
- From: Junio C Hamano <gitster@xxxxxxxxx>
- Subject: Re: [GSoC][PATCH v3 01/13] sequencer: make two functions and an enum from sequencer.c public
Alban Gruin <alban.gruin@xxxxxxxxx> writes:
> This makes rebase_path_todo(), get_missing_commit_check_level() and the
> enum check_level accessible outside sequencer.c. check_level is renamed
> missing_commit_check_level, and its value names are prefixed by
> MISSING_COMMIT_ to avoid namespace pollution.
It is not too big a deal, but we prefer to hear our story told in a
consistent voice. We'd phrase often the above as if giving an order
to the code base to "become like so", i.e.
Make X, Y, and Z accessible outside sequencer.c; rename A to
B and prefix its values by doing C to avoid namespace
> This function and this enum will eventually be moved to
> rebase-interactive.c and become static again, so no special attention
> was given to the naming.
> This will be needed for the rewrite of append_todo_help() from shell to
> C, as it will be in a new library source file, rebase-interactive.c.
> Signed-off-by: Alban Gruin <alban.gruin@xxxxxxxxx>
> Unchanged from v2.
You added an excuse for being sloppy in the naming to the log
message; the log message is an important and integral part of the
patch, so please do not label an update like this as unchanged.
"eventually" is fine, but that means we cannot split the early parts
of the topic, once they are polished well enough, into a separate
bit and have that graduate earlier than the remainder of the topic
until that "moved and become static again" happens, which may be a
bit unfortunate. Let's make sure we can get to that "eventually"