Re: [PATCH v2 8/9] gpg-interface: introduce new signature format "x509" using gpgsm
- Date: Tue, 10 Jul 2018 13:50:20 -0400
- From: Jeff King <peff@xxxxxxxx>
- Subject: Re: [PATCH v2 8/9] gpg-interface: introduce new signature format "x509" using gpgsm
On Tue, Jul 10, 2018 at 10:40:22AM -0700, Junio C Hamano wrote:
> > Extremely minor nit, but if there are no other uses of PGP_SIGNATURE etc
> > outside of this array (as I hope there wouldn't be after this series),
> > would it make more sense to just include the literals inline in the
> > array definition? That's one less layer of indirection when somebody is
> > reading the code.
> It is good design-sense to shoot for fewer levels of indirection,
> but I suspect that "'const char **' instead of maximally-sized fixed
> array of strings" would require a named array and constants like
Yes, I agree with that direction (because it drops the magic numbers and
lets us use existing argv_array helpers).
> so we may end up having the same number of levels of indirection
> anyway in the long-term final form.
True, but at least this level of indirection is buying us something. :)
> As readers may be able to read from the above, I also have a
> suspicion that it is a mistake to pretend that "--verify" etc.,
> which merely happen to be common across the variants the series
> covers, will stay forever to be common across _all_ variants and
> that is why the field no longer is called "extra" args but is meant
> to contain the full args.
I'd be fine going in that direction, too. But I don't actually foresee
adding new variants in the future. The point of this series versus the
signingtool one is that it's limited to gpg and gpg-alikes. And I doubt
we're likely to see more than the two that exist.
So even if we do end up adding support for more tools in the long run, I
think it will outgrow this config scheme.