Web lists-archives.com

Re: [RFC PATCH 1/1] completion: load completion file for external subcommand




Florian Gamböck <mail@xxxxxxxx> writes:

> Good point. I could go even further and ditch the if-construct:
>
>    ! declare -f $completion_func && declare -f __load_completion &&
>        __load_completion "git-$command"

I personally find that a lot harder to read than if/then/fi.