Web lists-archives.com

Re: Is support for 10.8 dropped?




On Sun, Apr 8, 2018 at 6:37 PM, Igor Korot <ikorot01@xxxxxxxxx> wrote:
> MyMac:git-2.17.0 igorkorot$ make configure
> GIT_VERSION = 2.17.0
>     GEN configure
> /bin/sh: autoconf: command not found
> make: *** [configure] Error 127
>
> Does this mean that something is a miss?

That means that you don't have the Autoconf tools installed, but don't
worry about it since use of the 'configure' script it very optional in
this project. Git tends to build just fine on most platforms without
running 'configure'. You should be able to get by just by typing
"make" in the git directory after downloading the source.

And, as noted earlier, before running "make", you may need to create
config.mak to override some settings documented at the top of Makefile
(in particular, you may want to set NO_GETTEXT if you don't want to
install gettext and don't think you'll need it). As prerequisite,
you'll probably need to install OpenSSL.