Web lists-archives.com

cc/require-tcl-tk-for-build, was Re: What's cooking in git.git (Nov 2017, #08; Tue, 28)




Hi Junio,

On Wed, 29 Nov 2017, Junio C Hamano wrote:

> * cc/require-tcl-tk-for-build (2017-11-27) 1 commit
>  - Makefile: check that tcl/tk is installed
> 
>  A first-time builder of Git may have installed neither tclsh nor
>  msgfmt, in which case git-gui and gitk part will fail and break the
>  build.  As a workaround, refuse to run a build when tclsh is not
>  installed and NO_TCLTK is not set.
> 
>  Undecided.
>  I still feel that requring tclsh to be installed, with or without
>  "escape hatch" for experts, may be too heavy-handed.

FWIW I agree, from a maintainer's point of view (even if Git for Windows
always had a working Tcl/Tk, I remember the times when I did not have the
luxury of tclsh being there, and my quota was not enough to allow for
compiling *both* emacs and Tcl/Tk on that box).

Ciao,
Dscho