Web lists-archives.com

Re: [PATCH 03/12] Makefile & configure: reword outdated comment about PCRE




On Sat, Apr 08, 2017 at 01:24:57PM +0000, Ævar Arnfjörð Bjarmason wrote:

> Reword an outdated comment which suggests that only git-grep can use
> PCRE.

Makes sense.

> -# Define USE_LIBPCRE if you have and want to use libpcre. git-grep will be
> -# able to use Perl-compatible regular expressions.
> +# Define USE_LIBPCRE if you have and want to use libpcre. Various
> +# commands such as like log, grep offer runtime options to use
> +# Perl-compatible regular expressions instead of standard or extended
> +# POSIX regular expressions.

s/such as like log, grep/such as log and grep/ ?

> diff --git a/configure.ac b/configure.ac
> [...]
> -# Define USE_LIBPCRE if you have and want to use libpcre. git-grep will be
> -# able to use Perl-compatible regular expressions.
> +# Define USE_LIBPCRE if you have and want to use libpcre. Various
> +# commands such as like log, grep offer runtime options to use
> +# Perl-compatible regular expressions instead of standard or extended
> +# POSIX regular expressions.

Ditto.

> @@ -499,8 +501,10 @@ GIT_CONF_SUBST([NEEDS_SSL_WITH_CRYPTO])
>  GIT_CONF_SUBST([NO_OPENSSL])
>  
>  #
> -# Define USE_LIBPCRE if you have and want to use libpcre. git-grep will be
> -# able to use Perl-compatible regular expressions.
> +# Define USE_LIBPCRE if you have and want to use libpcre. Various
> +# commands such as like log, grep offer runtime options to use
> +# Perl-compatible regular expressions instead of standard or extended
> +# POSIX regular expressions.

And again. It's weird that the text appears twice in configure.ac.
Apparently you can use --with-libpcre or USE_LIBPCRE in the environment?
Configure is weird.

-Peff