Web lists-archives.com

Re: [PATCH] Do not require Python for the git-remote-{bzr,hg} placeholder scripts




On Fri, Mar 03, 2017 at 10:57:46AM +0000, Sebastian Schuberth wrote:

> It does not make sense for these placeholder scripts to depend on Python
> just because the real scripts do. At the example of Git for Windows, we
> would not even be able to see those warnings as it does not ship with
> Python. So just use plain shell scripts instead.

Yeah, this seems like an obvious improvement. I think we got here
because the originals issued a warning but kept working, and then it was
slowly whittled down to remove the "working" part.

At some point these can probably go away. It's been 3 years since they
turned into nothing but warnings, so presumably most people have
upgraded by now (I know people often go a long time on old
distro-packaged versions, but the distro packagers would presumably
figure this out in the meantime).

OTOH, it is not really hurting much, so I do not mind keeping them
around for another 3 years (or more) just to catch any stragglers.

-Peff