Web lists-archives.com

Re: Buster/lightdm - after locking screen, unlock prompt not visible




On 5/31/19 11:16 AM, Raj Kiran Grandhi wrote:
> Hi,
> 
> In a fresh install of Buster with XFCE desktop, locking the screen
> blanks the monitor and the monitor enters a power save state. After
> that, neither moving the mouse nor typing on the keyboard would turn
> the monitor back on.
> 
> Typing the password without any visual feedback (while the monitor
> continues to be in the power save state) unlocks the screen and my
> session is displayed normally.
> 
> Also, switching to another VT when the monitor turns off and switching
> back displays the unlock prompt normally.
> 
> The closest I could find online was this:
> https://bbs.archlinux.org/viewtopic.php?id=240200 wherein installing
> the nouveau video driver appeared to have fixed the issue. However,
> that solution is not applicable in my case as I have an integrated
> intel graphics controller.
> 
> Is anybody else experiencing this bug? Any workaround?
> 
> Thanks,
> Raj Kiran
> 
> 
Hi, Raj.

Behavior on my testing systems with Xfce desktop environment is exactly
as you describe. I didn't think of it as a bug. There are lots of
lightweight lockers which behave similarly -- presenting a blank screen,
or perhaps a colored screen and awaiting password input without any kind
of feedback until the correct password is entered and the desktop
returns to normal.

I'm grateful for your post. I had never bothered to switch terminals to
see if it would have an effect. When I do so on these systems, I'm
presented with a screen with a message which says that the system is
locked and that I will be redirected to a login prompt in a few seconds.

I hope this is useful. Thank you for your post, as I prefer using a
prompt to typing my password at a blank screen.

Regards,
jp