Web lists-archives.com

Re: Fresh run of mmdebstrap - was [Re: Problems {PEBKAC?} running mmdebstrap for 1st time]




On 05/29/2019 03:04 PM, Jonas Smedegaard wrote:

mmdebstrap does not take debian-installer organized data as input.

According to the man page:
[https://manpages.debian.org/testing/mmdebstrap/mmdebstrap.1.en.html]
In contrast to debootstrap it uses apt to resolve dependencies
and is thus able to use more than one mirror and resolve more
complex dependencies.
AND later
--aptopt
Pass arbitrary options to apt.
As apt has no problem with ISOs. Why then should mmdebstrap have problem?

Also note the error message.
E: apt-get update -oAPT::Status-Fd=<$fd> -oDpkg::Use-Pty=false failed

It explicitly states "apt-get" has error.
Therefore I need the right mmdebstrap syntax.