Web lists-archives.com

Re: Problems {PEBKAC?} running mmdebstrap for 1st time




On 05/27/2019 12:08 PM, Cindy Sue Causey wrote:
On 5/27/19, Richard Owlett <rowlett@xxxxxxxxxxx> wrote:

Further re-reading of man pages suggests that my command should begin:
mmdebstrap --variant=required --aptopt="APT::Get::AllowUnauthenticated
true" ...

I hesitate to try that on this machine.


Is there any way to attempt a "--dry-run", or is that not offered? Or
it's possibly not even useful in this particular case usage?

The man page for mmdebstrap does mention one.
As its original motivation was to replace a sub-set of multistrap uses, I wouldn't be surprised if it exists.

I've just done a Debian install intended for doing dangerous experiments. But its lunch time.


I've encountered "--dry-run" as a nice option a couple times lately.
That's why it came to mind just now. Would be nice to see it here,
too.

DISCLAIMER: Where available, "--dry-run" is still not perfect. I've
seen it gloss over, i.e. not mention/reference at all, some forgotten
action that I had specifically needed to test-drive first before
attempting for reals.

That's essentially why I specified a tarball as output. Limits collateral damage while I find out what mmdebstrap does or can do.



Cindy :)