Web lists-archives.com

Re: Release netboot installer fails




On Sun 26 May 2019 at 11:18:52 -0400, Gregory Seidman wrote:

> This is mostly to document what I encountered, because I haven't had time
> to put it in a bug. (I don't know if I will get around to it, honestly. If
> someone else wants to put it in they should feel free and post a response
> to the list with the bug link.) I also have a bonus warning regarding
> encrypted root at the end.
> 
> First, the premise I'm working from:
> 
> 	The released netboot installer (i.e. netboot.tar.gz) downloadable via
> 	https://www.debian.org/distrib/netinst should be capable of
> 	installing the stable distribution, and should probably support any
> 	options it presents.
> 
> If there isn't agreement on that, well, don't even bother with the rest.
> 
> Using the amd64 netboot (pxelinux.0, etc.), I had my machine PXE boot.
> Everything boots and run fine until it tries to load installer components,
> at which point it apparently loads udebs from the testing distribution with
> kernel modules that don't match the installer kernel. At that point the
> installation cannot proceed since it can't find disks without the drivers
> for them (e.g. sd_mod).
> 
> I would have thought that the udebs for the stable distribution installer
> would remain (wait for it) stable. I'm a little unclear on whether there is
> any segregation of udebs by distribution at all. I haven't delved into the
> details of the installer, and I regret that I don't have time to do so, but
> I would hope this is fixable.

Bug #749991?

-- 
Brian.