Web lists-archives.com

Re: intermittent or not? "Could not resolve 'deb.debian.org'"




On 5/13/19 11:28 AM, Dan Ritter wrote:
The same command of course works perfectly fine when I connect the Teres
laptop directly to the internet with an ethernet cable (through USB).

I got this same behavior yesterday when firing up a new Debian
laptop. Turned out the wireless card was down.

Thanks Dan.

The card is not down.

Right now:

- My laptop from work opens https://fosdem.org and https://lists.debian.org with my home wifi router without any problem.

- My phone running LineageOS opens https://fosdem.org and https://lists.debian.org with my home wifi router without any problem.

- My Teres-I laptop cannot open https://fosdem.org nor https://lists.debian.org with my home wifi router, but with Ethernet/USB cable the pages opens just fine (cable connected to laptop directly from the wall, no router in between).

- My Teres-I laptop "Could not resolve 'deb.debian.org'" with wifi when asked to aptitude install something. But with Ethernet/USB it installs just fine (just as above).


However, right now, I can open lots of other web pages with my Teres-I laptop, and mail (Thunderbird) works fine (at least as far as I can tell, it's quite slow).

To me it seems like there is a wifi setting somewhere in my Teres-I laptop that is the reason for the intermittent(?) behavior, but of course it can be more complex than that.

Maybe a peek in the [source code] could shed some light on whether that could explain the behavior?

Unfortunately my Teres-I cannot reach the source code website either.

Maybe this is of general interest, so a code snippet with where wifi parameters are set could be interesting?

It would definitely be a great help for me.
 
//Erik

[source code] https://salsa.debian.org/tinker-team/box