Web lists-archives.com

update to new kernel




Hello.

I run Debian Unstable, 
Linux [user] 4.19.0-4-amd64 #1 SMP Debian 4.19.28-2 (2019-03-15) x86_64 GNU/Linux,
up to date.

Today, I did sudo aptitude -Pvv update as usual.  Result:

Current status: 0 (+0) broken, 4 (+4) upgradable, 59005 (-1) new.
There is 1 newly obsolete package: linux-image-4.19.0-4-amd64

Fine. So I did sudo aptitude -Pvvv full-upgrade. Result: 

sudo aptitude -Pvvv full-upgrade
The following packages will be upgraded: 
  exim4-base exim4-config exim4-daemon-light manpages 
4 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,332 kB of archives. After unpacking 31.7 kB will be used.
Do you want to continue? [Y/n/?] 
Get: 1 http://ftp.us.debian.org/debian unstable/main amd64 manpages all 4.16-2 [1,295 kB]
Get: 2 http://ftp.us.debian.org/debian unstable/main amd64 exim4-config all 4.92-7 [323 kB]
Get: 3 http://ftp.us.debian.org/debian unstable/main amd64 exim4-base amd64 4.92-7 [1,134 kB]
Get: 4 http://ftp.us.debian.org/debian unstable/main amd64 exim4-daemon-light amd64 4.92-7 [580 kB]
Fetched 3,332 kB in 2s (1,528 kB/s)         
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
Reading changelogs... Done
Preconfiguring packages ...
(Reading database ... 194666 files and directories currently installed.)
Preparing to unpack .../manpages_4.16-2_all.deb ...
Unpacking manpages (4.16-2) over (4.16-1) ...
Preparing to unpack .../exim4-config_4.92-7_all.deb ...
Unpacking exim4-config (4.92-7) over (4.92-5) ...
Preparing to unpack .../exim4-base_4.92-7_amd64.deb ...
Unpacking exim4-base (4.92-7) over (4.92-5) ...
Preparing to unpack .../exim4-daemon-light_4.92-7_amd64.deb ...
Unpacking exim4-daemon-light (4.92-7) over (4.92-5) ...
Setting up manpages (4.16-2) ...
Setting up exim4-config (4.92-7) ...
Setting up exim4-base (4.92-7) ...
Setting up exim4-daemon-light (4.92-7) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for systemd (241-3) ...
                                         
Current status: 0 (+0) broken, 0 (-4) upgradable, 59005 (+0) new. 

Okay . . .   So is there a new kernel?

I did: uname -a
Result: 
Linux [user] 4.19.0-4-amd64 #1 SMP Debian 4.19.28-2 (2019-03-15) x86_64 GNU/Linux

Then I did: sudo aptitude search linux-image
Result: 

i A linux-image-4.19.0-2-amd64                  - Linux 4.19 for 64-bit PCs (signed)                    
i A linux-image-4.19.0-3-amd64                  - Linux 4.19 for 64-bit PCs (signed)                    
i   linux-image-4.19.0-4-amd64                  - Linux 4.19 for 64-bit PCs (signed)                    
p   linux-image-4.19.0-4-amd64-dbg              - Debug symbols for linux-image-4.19.0-4-amd64          
p   linux-image-4.19.0-4-amd64-unsigned         - Linux 4.19 for 64-bit PCs                             
p   linux-image-4.19.0-4-cloud-amd64-dbg        - Debug symbols for linux-image-4.19.0-4-cloud-amd64    
p   linux-image-4.19.0-4-cloud-amd64-unsigned   - Linux 4.19 for x86-64 cloud                           
p   linux-image-4.19.0-4-rt-amd64-dbg           - Debug symbols for linux-image-4.19.0-4-rt-amd64       
p   linux-image-4.19.0-4-rt-amd64-unsigned      - Linux 4.19 for 64-bit PCs, PREEMPT_RT                 
p   linux-image-4.19.0-5-amd64                  - Linux 4.19 for 64-bit PCs (signed)                    
p   linux-image-4.19.0-5-amd64-dbg              - Debug symbols for linux-image-4.19.0-5-amd64          
p   linux-image-4.19.0-5-amd64-unsigned         - Linux 4.19 for 64-bit PCs                             
p   linux-image-4.19.0-5-cloud-amd64            - Linux 4.19 for x86-64 cloud (signed)                  
p   linux-image-4.19.0-5-cloud-amd64-dbg        - Debug symbols for linux-image-4.19.0-5-cloud-amd64    
p   linux-image-4.19.0-5-cloud-amd64-unsigned   - Linux 4.19 for x86-64 cloud                           
p   linux-image-4.19.0-5-rt-amd64               - Linux 4.19 for 64-bit PCs, PREEMPT_RT (signed)        
p   linux-image-4.19.0-5-rt-amd64-dbg           - Debug symbols for linux-image-4.19.0-5-rt-amd64       
p   linux-image-4.19.0-5-rt-amd64-unsigned      - Linux 4.19 for 64-bit PCs, PREEMPT_RT                 
p   linux-image-amd64                           - Linux for 64-bit PCs (meta-package)                   
p   linux-image-amd64-dbg                       - Debugging symbols for Linux amd64 configuration (meta-
p   linux-image-amd64-signed-template           - Template for signed linux-image packages for amd64    
p   linux-image-cloud-amd64                     - Linux for x86-64 cloud (meta-package)                 
p   linux-image-cloud-amd64-dbg                 - Debugging symbols for Linux cloud-amd64 configuration 
p   linux-image-rt-amd64                        - Linux for 64-bit PCs (meta-package), PREEMPT_RT       
p   linux-image-rt-amd64-dbg                    - Debugging symbols for Linux rt-amd64 configuration (me

So, since 
linux-image-4.19.0-5-amd64                  - Linux 4.19 for 64-bit PCs (signed) 
seems to be available, why did updating not update the kernel from 
linux-image-4.19.0-4-amd64 to linux-image-4.19.0-5-amd64?

And, BTW, when will Unstable ever get into the 5.x.x kernel series?