Web lists-archives.com

Re: Which nvidia driver am I using




Erwan David composed on 2019-05-04 20:52 (UTC+0200):

>>> I have some display problems
...
> Graphics:  Device-1: NVIDIA GF108M [NVS 5400M] vendor: Lenovo driver:
> nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:0def
>            Display: x11 server: X.Org 1.20.3 driver: modesetting
> unloaded: fbdev,vesa compositor: kwin_x11 tty: N/A
>            OpenGL: renderer: NVC1 v: 4.3 Mesa 18.3.4 direct render: Yes

> What are my options now ? I do not know where to begin looking for
> documentation on reparaing my install.
What are your "display problems"? How do you know the problem isn't Mesa or Kwin
or Plasma rather than a kernel or DDX driver? Have you tried disabling compositing
in systemsettings5? Does the trouble go away if you use a different WM? What was
the last thing you remember doing before "display problems" began? Does
/etc/X11/xorg.conf exist? If it does, try removing it. The nouveau DDX and
modesetting DDX almost never need it. Is there anything in /etc/X11/xorg.conf.d/?
If yes, what is in it? Upload your /var/log/Xorg.0.log where we can see it (man
pastebinit) and maybe someone can spot a problem. Inxi doesn't show the nouveau
DDX to be available. Maybe installing xserver-xorg-video-nouveau would improve
things. If it's already installed, an NVidia driver remnant might be blocking its use.
-- 
Evolution as taught in public schools is religion, not science.

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/