Web lists-archives.com

buster VM does not always start sshd




I've got a buster VM (upgraded from stretch) which does not launch
sshd (and Unbound) until a login attempt happens on a TTY.  (An
unsuccessful attempt appears to be enough.)

At that point, both sshd and Unbound start successfully, and network
login is possible.  I don't think I have changed the service
configuration.  There is nothing unusual about the networking setup,
except that it doesn't use DHCP, and there is a static stanza in
/etc/network/interfaces, with a matching auto directive.

● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enab
   Active: active (running) since Sat 2019-05-04 17:47:31 UTC; 8min ago
     Docs: man:sshd(8)
           man:sshd_config(5)
  Process: 684 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
 Main PID: 694 (sshd)
    Tasks: 1 (limit: 1149)
   Memory: 3.1M
   CGroup: /system.slice/ssh.service
           └─694 /usr/sbin/sshd -D

May 04 17:46:20 storage1 systemd[1]: Starting OpenBSD Secure Shell server...
May 04 17:47:31 storage1 sshd[694]: Server listening on 0.0.0.0 port 22.
May 04 17:47:31 storage1 sshd[694]: Server listening on :: port 22.
May 04 17:47:31 storage1 systemd[1]: Started OpenBSD Secure Shell server.
May 04 17:48:04 storage1 sshd[708]: Accepted publickey for fw from 172.17.151.1 
May 04 17:48:04 storage1 sshd[708]: pam_unix(sshd:session): session opened for u

● unbound.service - Unbound DNS server
   Loaded: loaded (/lib/systemd/system/unbound.service; enabled; vendor preset: 
   Active: active (running) since Sat 2019-05-04 17:47:32 UTC; 9min ago
     Docs: man:unbound(8)
  Process: 683 ExecStartPre=/usr/lib/unbound/package-helper chroot_setup (code=e
  Process: 687 ExecStartPre=/usr/lib/unbound/package-helper root_trust_anchor_up
 Main PID: 695 (unbound)
    Tasks: 1 (limit: 1149)
   Memory: 8.0M
   CGroup: /system.slice/unbound.service
           └─695 /usr/sbin/unbound -d

May 04 17:46:20 storage1 systemd[1]: Starting Unbound DNS server...
May 04 17:47:32 storage1 package-helper[687]: /var/lib/unbound/root.key has cont
May 04 17:47:32 storage1 package-helper[687]: success: the anchor is ok
May 04 17:47:32 storage1 unbound[695]: [695:0] notice: init module 0: subnet
May 04 17:47:32 storage1 unbound[695]: [695:0] notice: init module 1: validator
May 04 17:47:32 storage1 unbound[695]: [695:0] notice: init module 2: iterator
May 04 17:47:32 storage1 unbound[695]: [695:0] info: start of service (unbound 1
May 04 17:47:32 storage1 systemd[1]: Started Unbound DNS server.

As far as I can tell, the system reaches multi-user.target
successfully, at which point I expect that sshd.service can start as
well:

● multi-user.target - Multi-User System
   Loaded: loaded (/lib/systemd/system/multi-user.target; static; vendor preset:
   Active: active since Sat 2019-05-04 17:34:16 UTC; 22min ago
     Docs: man:systemd.special(7)

May 04 17:34:16 storage1 systemd[1]: Reached target Multi-User System.

Any suggestions how to debug this further?  I don't think this
happened with Debian stretch.