Web lists-archives.com

Re: Obtaining/compiling/installing python3.7




Richard Owlett wrote:

> I wish to try some beta software which assumes python3.7 is installed. I
> have Debian 9.8 installed on a machine dedicated to this exercise. I did
> a web search and got a half dozen on topic hits. There were enough
> differences that I wasn't sure if I was missing something important. The
> last time I compiled something was on a PDP 11/45 in approximately 1975.
> 
> Suggestions?
> TIA

Try the pip python repositories
https://docs.python.org/3/installing/index.html#install-pip-in-versions-of-python-prior-to-python-3-4

I recall I used it with ansible on debian with 2.7 where I needed python3.
I am not sure it will give you exactly what you need, but may be it would.