Web lists-archives.com

Re: P2V Debian 9 with VMware Converter




Hi Calbaza,

I'm not surprised it works for Debian 8 (released in 2015) as the tool officially supports Ubuntu 16 (released in 2016).

It also works like a charm for Debian 7 (2013) but not Debian 9 (2017).

All my VMs run as version 11 too.

It fails with the same error when tried against 3 different ESXi hosts (6.0, 6.0 and 6.7) running on 2010, 2015 and 2017 server hardware respectively.

I think the errors are misleading and it should start working in one of the next releases on VMware vCenter Converter Standalone.

I'm now giving Veeam a shot on this (which also doesn't require source machine to be shut down).

If it fails I will resort to old school manual VM creation and data copying.

Thanks,
Adam


On 15/02/19 15:38, Calabaza wrote:

I convert about 17 Debian machines with Debian 8 with little or no problem.
(I understand that you need Debian 9 but that is my experience).

I'm think your problem is about the virtual hardware versión of
destination in your ESX.

I have all my machines with Virtual Hardware version: 11

Read this links, may be help you:

[0] What other requirements and considerations are there for virtual
machines with EFI firmware?
[0] https://communities.vmware.com/docs/DOC-28494
[1] https://communities.vmware.com/thread/519642

Here [2] say that

"(...) EFI firmware is supported from hardware version 11 and above. (...)"

[2] https://communities.vmware.com/thread/584625
[3] https://akmyint.wordpress.com/2012/09/30/my-p2v-notes-stand-alone-servers-or-non-clustered/

I'm a Spanish speaker, sorry for my bad English.