Web lists-archives.com

Installer can't find network interface on Intel NUC BOXNUC8i3BEH1




I recently bought an intel NUC BOXNUC8i3BEH1.  You can see a description of the product at Newegg:
    https://www.newegg.com/Product/Product.aspx?Item=N82E16856102213

I’m trying to install Debian Stretch on it
    debian-9.7.0-amd64-DVD-1.iso
and (later)
    firmware-9.6.0-amd64-DVD-1.iso

I made a bootable USB stick the usual way with dd to copy the iso to the stick.  It boots fine and loads some preliminary stuff.  When it gets to trying to identify the network interface, it fails at that task and drops into a screen with a long list of network drivers for me to choose from.

I didn’t know what driver to load (the Newegg description says it uses an Intel networking chip, but I didn’t know which driver was needed by that chip)  So I aborted the installation.  On a hunch, I then tried to install Ubuntu (ubuntu-mate-18.04-desktop-amd64.iso) and that works fine.  The network comes up automatically.

So, on Ubuntu, I typed “lspci -v” and searched the output for the network interface.  It says that the driver installed for that interface is “e1000e”.  A quick check on a working Stretch system shows that the e1000e driver *is* available in Debian.  So, I think to myself, “Problem solved — all I have to do is specify the e1000e driver and all will be well!”

Not so fast…  I boot the Debian “firmware-9.6…” stick and it gets to the list of drivers.  I pick e1000e (with is there, along with a bunch of other Intel drivers) and go back to see if it now can see the interface.   Nope!   It still isn’t seeing the network.


What am I missing?  What is Ubuntu doing to make this work that Debian doesn’t?


Anybody got any suggestions???

Thanks in advance,
Rick