Web lists-archives.com

Re: Sid: APC Smart-UPS 1500 & nut




On 11.02.2019 16:20, Grzesiek Sójka wrote:
Hi there,

Ups is connected via usb:

Bus 003 Device 002: ID 051d:0002 American Power Conversion Uninterruptible Power Supply

Recently I noticed that nut stopped to recognize it (probably after some update):

# /lib/nut/usbhid-ups -a APC
Network UPS Tools - Generic HID driver 0.41 (2.7.4)
USB communication driver 0.33
No matching HID UPS found
# cat /etc/nut/ups.conf
[APC]
    driver = usbhid-ups
    port = auto

I did try to fix the problem by adding vendor or product options or changing the driver but no luck.

Any suggestions? Is the driver correct?

I don't know about nut, but I had similar problems with APC SU1500 models in the past.
They had some kind of firmware bug, or hardware problem with USB interface and sporadically loose connectivity to host. Also there was no way to recover UPS from this state other than performing "cold reset" procedure. [1] After that USB connectivity was restored and continued to function until this bug is triggered again, which could happen in a span from few hours to weeks.
In the end I've resolved this nightmare by creating custom 9pin COM-to-COM cables [2] [3] and stopped to use USB ports. Additionally, in some cases I had to reprogram UPS firmware via terminal, [4] to get it working again and be discovered by management software. This also could be useful to perform basic connectivity diagnostics.

There are some bookmarks I saved about this problem that could be useful:
[1] https://www.schneider-electric.com/en/faqs/FA156611/
[2] http://news-posts.aplawrence.com/472.html
[3] http://pinoutguide.com/UPS/apc_smart_cable_pinout.shtml
[4] http://www.joeteck.com/apc.htm

-- 
With kindest regards, Alexander.

⢀⣴⠾⠻⢶⣦⠀ 
⣾⠁⢠⠒⠀⣿⡁ Debian - The universal operating system
⢿⡄⠘⠷⠚⠋⠀ https://www.debian.org
⠈⠳⣄⠀⠀⠀⠀