Web lists-archives.com

USB flash drive with an encrypted partition not showing on desktop




Hi,

My problem is that I can't make a USB flash drive with a LUKS encrypted
partition be shown on desktop when is inserted. It's a fresh installation
of Debian Buster with xfce4.

Partitions in USB device:
------------
# fdisk -l /dev/sdb
Disco /dev/sdb: 28,7 GiB, 30752000000 bytes, 60062500 sectores
Modelo de disco: Ultra           
Unidades: sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico/físico): 512 bytes / 512 bytes
Tamaño de E/S (mínimo/óptimo): 512 bytes / 512 bytes
Tipo de etiqueta de disco: dos
Identificador del disco: 0x9bf8c0c7

Disposit.  Inicio Comienzo    Final Sectores Tamaño Id Tipo
/dev/sdb1             2048   600063   598016   292M 83 Linux
/dev/sdb2           600064 48050175 47450112  22,6G 83 Linux
/dev/sdb3         48650240 60061695 11411456   5,5G 83 Linux
------------
The encrypted partition is /dev/sdb3

I can mount it manually but for ease use I would prefer doing it from
desktop ...
I got it running fine before (in testing) and is working in a stable system.
I have these packages installed:
------------
$ sudo aptitude search "(?installed)gvfs"
i   gvfs                 - sistema de archivos virtual de espacio de usuario
i   gvfs-backends        - userspace virtual filesystem - backends          
i A gvfs-common          - sistema de archivos virtual de espacio de usuario
i A gvfs-daemons         - sistema de archivos virtual de espacio de usuario
i   gvfs-fuse            - userspace virtual filesystem - fuse server       
i A gvfs-libs            - sistema de archivos virtual de espacio de usuario

$ sudo aptitude search "(?installed)cryptsetup"
i   cryptsetup           - transitional dummy package for cryptsetup-{run,in
i A cryptsetup-bin       - disk encryption support - command line tools     
i A cryptsetup-initramfs - disk encryption support - initramfs integration  
i A cryptsetup-run       - disk encryption support - startup scripts        
i   libcryptsetup12      - disk encryption support - shared library
------------
I have compared stable installation with this one and I can't find what is
missing ...
I'd appreciate if you could help me.

Thank you and regards!