Web lists-archives.com

Re: Package dependancies.




Hi,

On Tue, 05 Feb 2019 13:42:41 -0800
peter@xxxxxxxxxxx wrote:

> Any ideas about this? 
> 
> root@imager:/etc/apt# apt-get install aptitude
> Reading package lists... Done
> Building dependency tree       
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>  aptitude : Depends: aptitude-common (= 0.6.11-1) but 0.8.7-1 is to be
> installed

0.8.7 is the version from Stretch, 0.6.11 the version from Jessie.

So the question arises, what are the contents of your sources.list
file(s)? Did you change anything about these recently? Did you try to do 
'apt-get update' first and then try to install aptitude again?


Regards

Michael



.-.. .. ...- .   .-.. --- -. --.   .- -. -..   .--. .-. --- ... .--. . .-.

[War] is instinctive.  But the instinct can be fought.  We're human
beings with the blood of a million savage years on our hands!  But we
can stop it.  We can admit that we're killers ... but we're not going
to kill today.  That's all it takes!  Knowing that we're not going to
kill today!
		-- Kirk, "A Taste of Armageddon", stardate 3193.0