Web lists-archives.com

Re: logout kills X




On Wed 30 Jan 2019 at 19:12:42 (+0000), Brian wrote:
> On Wed 30 Jan 2019 at 13:48:17 -0500, Felix Miata wrote:
> > hohe72@xxxxxxxx composed on 2019-01-30 18:38 (UTC+0100):
> > 
> > > I logged in (to tty1)
> > > started X (startx)
> > > switched to tty2
> > > logged in (using the same name)
> > > logged out
> > 
> > > -> X on tty1 crashes
> > 
> > Same problem if you don't use tty1, instead logging in first on tty2, and after on tty3?
> 
> Did *you* try this? In fact, did *you* even try the procedure that
> hohe72 describes so well?

I've tried this every time I've seen it reported, and nothing ever
freezes, or crashes. Same just now.

But I do remember reading at one time that there's "something
different" about VC1 from the other consoles, and this change
was suggested as a possible workaround.

Whether it worked? No idea.
Whether the suggester (in the past) had had the same problem? No idea.
Does it have any effect? Not here, but then, I don't have the problem.
(Apart from the effect of a lot of 2s instead of 1s in the logs.
Oh, and a spent tty3 hanging around. I thought someone recently
posted that they got tidied up, but I've never seen that happen here.)

 1091     1     0 tty2     Ss     0:00 /bin/login --
 1193     1  1000 ?        Ss     0:00 /lib/systemd/systemd --user
 1195  1193  1000 ?        S      0:00 (sd-pam)
 1197  1091  1000 tty2     S+     0:00 -bash
 1284     1     0 ?        Ss     0:00 wpa_supplicant -B -i wlp2s0 -c /var/lib/wicd/configurations/b
 1354     1     0 ?        Ss     0:00 /sbin/dhclient -v -cf /var/lib/wicd/dhclient.conf wlp2s0
 1416  1197  1000 tty2     S      0:00 /bin/sh /usr/bin/X11/startx
 1438  1416  1000 tty2     S      0:00 xinit /etc/X11/xinit/xinitrc -- /etc/X11/xinit/xserverrc :0 v
 1439  1438  1000 tty2     Sl     0:01 /usr/lib/xorg/Xorg -nolisten tcp :0 vt2 -keeptty -auth /tmp/s
 1443  1439     0 tty2     S      0:00 /usr/lib/xserver-xorg-video-intel/xf86-video-intel-backlight-
 1446     1     0 ?        Ssl    0:00 /usr/lib/policykit-1/polkitd --no-debug
 1455  1438  1000 tty2     S      0:00 /bin/bash /home/david/.xsession
 1482     1  1000 tty2     S      0:00 /usr/bin/dbus-launch --exit-with-session --sh-syntax
 1483     1  1000 ?        Ss     0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 -
 1501  1455  1000 ?        Ss     0:00 /usr/bin/ssh-agent /bin/bash /home/david/.xsession

[…]

 2300     1     0 tty3     Ss+    0:00 /sbin/agetty --noclear tty3 linux

Disclaimers:
I run stretch. The OP's kernels look much newer.
I don't run a DE, just fvwm. Does the OP?
I know I've run two X sessions, but can't remember if I used the same
user. Is the OP running two sessions, or just one X and some VCs?
I don't claim to understand all the output posted here,
especially the last paragraph.

Cheers,
David.