Web lists-archives.com

Re: The Dark Mod on Stretch?




Thanks for your patience -- trying this now...

Did you get the following errors?

game/StimResponse/StimResponseTimer.cpp: At global scope:
game/StimResponse/StimResponseTimer.cpp:22:62: error: non-constant
condition for static assertion
 static_assert((size_t)&((TimerValue*)NULL)->Time.Millisecond == 4,
"TimerValue type has wrong packing");
               ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~
game/StimResponse/StimResponseTimer.cpp:22:62: error: dereferencing a
null pointer in ‘*0’
game/StimResponse/StimResponseTimer.cpp:23:61: error: non-constant
condition for static assertion
 static_assert((size_t)&((TimerValue*)NULL)->Val.Millisecond == 4,
"TimerValue type has wrong packing");
               ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~
game/StimResponse/StimResponseTimer.cpp:23:61: error: dereferencing a
null pointer in ‘*0’


Cheers!

On Tue, Jan 8, 2019 at 3:08 PM Reco <recoverym4n@xxxxxxxxxxxx> wrote:
>
>         Hi.
>
> On Tue, Jan 08, 2019 at 08:22:53AM -0500, Boyan Penkov wrote:
> > Hello,
> >
> > Anybody here play http://www.thedarkmod.com/main/ <http://www.thedarkmod.com/main/> ?
>
> I wish ☹
>
> >  have folks been able to get 2.07 to compile on Stretch, under only 64-bit?
>
> I could try if you provide me the source. 2.06, which I took from [1],
> can be built like this:
>
> 1) Build-deps:
>
> apt install scons m4 subversion mesa-common-dev libxxf86vm-dev \
>         libopenal-dev libxext-dev
> apt purge libcurl4-gnutls-dev
>
> 2) Patching:
>
> patch -p1 -i /tmp/01-multilib.patch
> patch -p1 -i /tmp/02-ffmpeg.patch
>
> 3) Building:
>
> scons BUILD="release" TARGET_ARCH="x64" -j`nproc`
>
>
> Of course, doing it the proper way (unbundling all the libraries, fixing
> signed/unsigned mixups, etc), wrapping the thing into a package - is
> outside of scope of this mini-howto.
>
> Reco
>
> [1] http://www.thedarkmod.com/downloads/



-- 
Boyan Penkov