Web lists-archives.com

/dev/disk/by-id/ in testing




Hi,

my weekly upgrade on testing failed yesterday as,  after an initrd.img was generated, lilo could not run successfully.

After checking my /etc/lilo.conf, where I had my boot disk identified by ID as :

"boot=/dev/disk/by-id/ata-ST3500320AS_9QM6D0TB"

and comparing it with what is in /dev/disk/by-id I noticed that this identification-id had changed suddeny: see the additional underscores in the names of both harddisks:

$ ls -alF /dev/disk/by-id/

total 0
drwxr-xr-x 2 root root 700 jan  6 11:00 ./
drwxr-xr-x 7 root root 140 jan  6 10:32 ../
lrwxrwxrwx 1 root root   9 jan  6 10:32 ata-PIONEER_DVD_RW_DVR-107D -> ../../sr0
lrwxrwxrwx 1 root root   9 jan  6 10:32 ata-ST3500320AS____9QM6D0TB -> ../../sdb
lrwxrwxrwx 1 root root  10 jan  6 10:32 ata-ST3500320AS____9QM6D0TB-part1 -> ../../sdb1
lrwxrwxrwx 1 root root  10 jan  6 10:32 ata-ST3500320AS____9QM6D0TB-part2 -> ../../sdb2
lrwxrwxrwx 1 root root  10 jan  6 10:32 ata-ST3500320AS____9QM6D0TB-part5 -> ../../sdb5
lrwxrwxrwx 1 root root  10 jan  6 10:32 ata-ST3500320AS____9QM6D0TB-part6 -> ../../sdb6
lrwxrwxrwx 1 root root  10 jan  6 10:32 ata-ST3500320AS____9QM6D0TB-part7 -> ../../sdb7
lrwxrwxrwx 1 root root  10 jan  6 10:32 ata-ST3500320AS____9QM6D0TB-part8 -> ../../sdb8
lrwxrwxrwx 1 root root   9 jan  6 10:32 ata-WDC_WD10EZRX-00L4HB0____WD-WCC4J1SLKT9F -> ../../sda
lrwxrwxrwx 1 root root  10 jan  6 10:32 ata-WDC_WD10EZRX-00L4HB0____WD-WCC4J1SLKT9F-part1 -> ../../sda1
lrwxrwxrwx 1 root root  10 jan  6 10:32 ata-WDC_WD10EZRX-00L4HB0____WD-WCC4J1SLKT9F-part2 -> ../../sda2
lrwxrwxrwx 1 root root  10 jan  6 10:32 ata-WDC_WD10EZRX-00L4HB0____WD-WCC4J1SLKT9F-part5 -> ../../sda5
lrwxrwxrwx 1 root root  10 jan  6 10:32 ata-WDC_WD10EZRX-00L4HB0____WD-WCC4J1SLKT9F-part6 -> ../../sda6
lrwxrwxrwx 1 root root  10 jan  6 10:32 ata-WDC_WD10EZRX-00L4HB0____WD-WCC4J1SLKT9F-part7 -> ../../sda7
lrwxrwxrwx 1 root root  10 jan  6 10:32 ata-WDC_WD10EZRX-00L4HB0____WD-WCC4J1SLKT9F-part8 -> ../../sda8

in my lilo.conf I have now (after correction):

#boot=/dev/sda
#boot = /dev/disk/by-id/ata-WDC_WD10EZRX-00L4HB0_WD-WCC4J1SLKT9F
#boot=/dev/disk/by-id/ata-WDC_WD10EZRX-00L4HB0____WD-WCC4J1SLKT9F

#boot=/dev/sdb
boot=/dev/disk/by-id/ata-ST3500320AS____9QM6D0TB
#boot=/dev/disk/by-id/ata-ST3500320AS_9QM6D0TB

My question: is this change intentional?  I thought I was "save";-) identifying my disks by ID ? Or did I miss something?

Thanks for any clarification and best regards,

Johan