Web lists-archives.com

Re: Firefox, gnome-terminal, nautilus, transmission-gtk slow to start




Vas Vas wrote:
> I recently upgraded to testing, and certain applications take an excessive amount of time to start. So far I've experienced it with firefox-esr, gnome-terminal, nautilus, and transmission-gtk, and it ranges from 20 to 90 seconds of delay beyond what's normal.

  this sounds a lot like some other reports of issues and they
relate to not having enough random noise aka entropy that is 
being used to set up the system random number generators for 
various types of encryption.


> Once one of those applications starts, all the problematic applications revert to their usual behaviour as in stable, and start at a reasonable time. This remains true until the next power cycle, where the problem reappears.
>
> Other applications, such as xterm, tint2, openbox, emacs, gimp, or evince behave the same as before and don't exhibit the bug.
>
> I've been trying to debug the problem but I haven't found much. I've tried using a GNOME session instead of an Openbox session, and the problem persists. I've also tried an strace output with timestamps for any hints, but I couldn't get anything out of it, though TBH I'm not very good at reading it.
>
>>From the characteristics of the problem I suspect something related to caching, a daemon, or networking, but I don't know what else to do to investigate it. If anyone has any hints that would help me figure it out, that would be awesome!


  songbird