Web lists-archives.com

Mouse wheel scrolling hesitates




Hi,
My mouse wheel behaves in a bit strange way.

Right after moving into an application window, neither up nor down
scroll works until the second wheel "bump." Subsequent scrolls work fine
until I move out from the window.

I use stretch (9.5 or maybe 9.6) mate desktop on AMD E-450, USB-wired
Logitec mouse.

Now the funny part: some application respond to the wheel scroll right
from the first bump; some don't.

In stretch 9.5 installed mate desktop:
	atril,
	frefox, and
	thunderbird work fine;

	caja,
	libreoffice,
	pluma, and
	mate-terminal miss the first bump;

In stretch 9.5.0 live mate desktop:
	(debian-live-9.5.0-amd64-mate.iso)
	atril,
	firefox,
	pluma, and
	mate-terminal work fine;

	caja and
	libreoffice miss the first bump;

In stretch 9.6 live mate desktop:
	(debian-live-9.6.0-amd64-mate.iso)
	atril,
	firefox,
	pluma, and
	mate-terminal work fine;

	caja and
	libreoffice miss the first bump;

In stretch 9.6 live gnome desktop:
	(debian-live-9.6.0-amd64-gnome.iso)
	firefox works fine;

	evince,
	gedit,
	libreoffice,
	nautilus, and
	gnome-terminal miss the first bump;

In jessie 8.11 live mate-desktop:
	(debian-live-8.11.0-amd64-mate-desktop.iso)
	all above mentioned programs work fine.

Zoom-up/down by a mouse wheel behave the same way. That is, works fine
on the good program window, miss the first ctrl/wheel-up-or-down on the
unfortunate program window.

If you have two USB mice connected, say A and B, alternate 'wheeling'
responds similarly, like,
A-up-one,
B-up-one,
A-down-one,
B-up-one...will never get any response from unfortunate programs.

Any suggestions?

Fred
(not a member of this mailing list, yet)