Web lists-archives.com

Re: modprobe bbswitch fails




On 27.11.2018 2:03, Johann Spies wrote:
Trying to get my nvidia-card to work properly following tutorials like https://www.pcsuggest.com/install-and-configure-nvidia-optimus-with-bumblebee-in-debian/ and https://www.pcsuggest.com/nvidia-optimus-troubleshooting-in-debain-kali-linux-ubuntu/ I fail to get pass the step where I have to do
"sudo modprobe bbswitch load_state=0"

It ends in

bbswitch: No suitable _DSM call found
modprobe: ERROR: could not insert 'bbswitch': no such device

This is on a HP Zbook 15 laptop which I recently bought with a NVIDIA GK107GLM [ Quadro K1100M] VGA compatable controller.

I have searched the internet for a solution but nothing so far worked for me.

Most of the information I found, was old and referred to bugs in older kernels.
I have 4.18.0-2-amd64 #1 SMP on my system.

Any idea about the way forward?

Regards
Johann




--
Because experiencing your loyal love is better than life itself,
my lips will praise you.  (Psalm 63:3)
I suggest to check if your laptop has latest Firmware\BIOS update installed. That is first thing I would check if I got similar error message.
Update it to the latest one provided by HP support website.
Also check if there are some settings in BIOS, saying Optimus or Hybrid Graphics that could be tweaked.

Check out similar bug report on GitHub [1]. Some people reported they fixed it by installing 4.19 kernel, which probably contain more compatibility fixes for exotic hardware.

[1] https://github.com/Bumblebee-Project/bbswitch/issues/160
-- 
With kindest regards, Alexander.

⢀⣴⠾⠻⢶⣦⠀ 
⣾⠁⢠⠒⠀⣿⡁ Debian - The universal operating system
⢿⡄⠘⠷⠚⠋⠀ https://www.debian.org
⠈⠳⣄⠀⠀⠀⠀