Web lists-archives.com

Re: keyboard configuration issue




*Whoops!* The mangled one that's working is *BUSTER*, not Stretch.
Just realized that as I ran another "apt-get update". That's comparing
apples and oranges in that case with respect to 1 1/2 to ~2-year-old
Buster's keyboard working while shiny new Stretch's is being a tiny
bit flaky. Sorry about that. :)


On 11/21/18, Cindy-Sue Causey <butterflybytes@xxxxxxxxx> wrote:
> On 11/21/18, redmood <red-contact@xxxxxxxxxx> wrote:
>> Hello,
>>
>> I just installed debian 9 on my laptop. I encrypted the disk, so I have
>> to type a keyphrase before accessing the data on the disk. I also have a
>> user account and have to type my password to log in. I have been trying
>> to set the french bepo keyboard, instead of the default azerty one. I
>> followed the instruction from this link :
>> https://wiki.debian.org/Keyboard
>>
>>  From this point, when I had to type my password to decrypt the disk, I
>> had to type in azerty, but when I had to log in my user account, I had
>> to type the password with the bepo keyboard. And then, once logged in,
>> the keyboard was set back to the classic french azerty layout again. So
>> I tried the commands given in the first answer here :
>> https://superuser.com/questions/646425/permanently-change-default-language-and-keyboard-settings-what-am-i-missing
>>
>> Now, when I power on my computer, I have to type the decrypt password in
>> bepo as well as my log in password, but once logged in, the layout is
>> still set back to the azerty layout.
>>
>>
>> How can I force the layout to stay consistent once logged in my user
>> account ?
>
>
> Hi.. Do you have a(n) Fn key that comes into play at all? I'm on an
> older ASUS 1015px (looks like a happy little Valentine card, grin). I
> just in the last couple hours rsync'ed over a newly debootstrap'ed
> Stretch to it. Hadn't done that in a LONG time. Means everything is
> nice and shiny new.
>
> BUT.. It's currently not recognizing my LAN wired network so I'm
> rebooting in and out while searching the Internet for answers then
> going back in to try to fix things...
>
> EVERY TIME I boot back in, I don't get letters, I get numbers when I
> click those particular keys in the middle of the keyboard. It was
> obvious that the Fn function had been triggered somehow. I seriously
> thought the dogs did it... the FIRST time it happened.
>
> The immediate fix for THAT is to hit my Fn key along with the numlock
> one at the end of the top row. A painless pain... :)
>
> Rerunning "dpkg-reconfigure keyboard-configuration" didn't change the
> outcome on the next couple reboots...
>
> I'm not in there right now, but my uname is similar to "Linux
> northpole 4.9.0-6-amd64" with a
> date that was maybe May of this year?
>
> That version's older, SERIOUSLY frazzled, borked, mangled sister here
> (4.9.0-1-amd64 #1 SMP Debian 4.9.2-2 2017-01-12 x86_64) is working
> fine for both recognizing the LAN network AND not touching my Fn key
> on every reboot.
>
> There are some 390+ packages currently on Developer inspired hold in
> my old botched system here. Dpkg is on hold, but things like locales
> and console-setup are not. Wonder if one of the ones on hold for this
> older setup is the offender that found its way into the shiny new
> version where no packages are currently on Developer hold...
>
> OR NOT. :)
>
> Cindy :)
> --
> Cindy-Sue Causey
> Talking Rock, Pickens County, Georgia, USA
>
> * runs with duct tape *