Web lists-archives.com

Re: glibc_2.27-8 build fails on Butcher (testing)




As the tutorial ( https://wiki.debian.org/BuildingTutorial ) says,

download with "apt-get source libc6" in my ~/work-glibc, and cd
glibc-2.27, then download build dependencies with "sudo apt-get
build-dep libc6", then rebuild with "debuild -b -uc -us".

After a while, I got these errors.  But I might run "debuild -b -uc -us"
in ~/work-glibc/glibc-2.27/debian.  Does it matter?

Best regards,


On 11/20/18 2:30 PM, Roberto C. Sánchez wrote:
> On Tue, Nov 20, 2018 at 02:06:17PM +0900, Tetsuji Rai wrote:
>> Hi all,
>>
>> I'm trying to build several packages from their source packages, however
>> I have not succeeded in building glibc_2.27-8.   It always fails telling
>> ndbm.h and varargs.h (or stdarg.h) in testsuite building, although I
>> have installed libgdbm-compat-dev (including /usr/include/ndbm.h) and
>> stdarg.h, varargs.h (in libstdc++-7-dev and libstdc++-8-dev).  Error
>> messages are as follows.  These appear many times because they are tried
>> many times.
>>
>>
>> Anyone have clues?   I am sure many people have done this.
> What commands are you using to build the package?  This includes the
> commands to download the package and, if applicable, unpack/prepare it
> for the build.
>
> Regards,
>
> -Roberto
>