Web lists-archives.com

glibc_2.27-8 build fails on Butcher (testing)




Hi all,

I'm trying to build several packages from their source packages, however
I have not succeeded in building glibc_2.27-8.   It always fails telling
ndbm.h and varargs.h (or stdarg.h) in testsuite building, although I
have installed libgdbm-compat-dev (including /usr/include/ndbm.h) and
stdarg.h, varargs.h (in libstdc++-7-dev and libstdc++-8-dev).  Error
messages are as follows.  These appear many times because they are tried
many times.


Anyone have clues?   I am sure many people have done this.


Thanks in advance!!   Best regards,


-Tetsuji

--------------------------------errors
1--------------------------------------

XFAIL: conform/UNIX98/ndbm.h/conform
original exit status 1
Testing <ndbm.h>
----------------
  Checking whether <ndbm.h> is available... FAIL
    Header <ndbm.h> not available  Compiler message:
    -----------------------------------------------------------------------
   
/home/tetsuji/work-glibc/glibc-2.27/build-tree/amd64-libc/conform/UNIX98/ndbm.h/scratch/ndbm.h-test.c:1:10:
fatal error: ndbm.h: No such file or directory
     #include <ndbm.h>
              ^~~~~~~~
    compilation terminated.
    -----------------------------------------------------------------------

  Checking the namespace of "ndbm.h"... SKIP
---------------------------------errors
2-------------------------------------

XFAIL: conform/UNIX98/varargs.h/conform
original exit status 1
Testing <varargs.h>
-------------------
  Checking whether <varargs.h> is available... FAIL
    Header <varargs.h> not available  Compiler message:
    -----------------------------------------------------------------------
    In file included from
/home/tetsuji/work-glibc/glibc-2.27/build-tree/amd64-libc/conform/UNIX98/varargs.h/scratch/varargs.h-test.c:1:0:
    /usr/lib/gcc/x86_64-linux-gnu/7/include/varargs.h:4:2: error: #error
"GCC no longer implements <varargs.h>."
     #error "GCC no longer implements <varargs.h>."
      ^~~~~
    /usr/lib/gcc/x86_64-linux-gnu/7/include/varargs.h:5:2: error: #error
"Revise your code to use <stdarg.h>."
     #error "Revise your code to use <stdarg.h>."
      ^~~~~
    -----------------------------------------------------------------------

  Checking the namespace of "varargs.h"... SKIP