Web lists-archives.com

latest Stretch update breaks Scribus!




This is one of the those WTF moments. Despite the fact that Ghostscript 9.25 has been known to break Scribus since at least the start of the month, the Stable version of Ghostscript has just been changed from 9.22 to 9.25.

This was apparently done to patch a security hole - possibly https://www.cvedetails.com/cve/CVE-2018-10194/ found in 2018-04-18. However it seems to me that the cure is worse than the disease since it now renders an important (for me, anyway) application useless. Instead I need to keep the old version of Ghostscript on my laptop in order to be able to import EPS & PDF files and export the document to PDF.

I recognize that there is no perfect solution to this problem but breaking an existing program should not be allowed within the Stable branch.

I'm glad that I luckily created a virtual machine running Stretch just as the upgrade to Ghostscript was added to Stable so that I can stop it from affecting my laptop. At least I still have a machine that can handle Scribus documents containing PDFs. However I believe the maintainers should roll back the update until they have a version that works with Scribus.