Web lists-archives.com

Re: discover and install specific package version




Reco composed on 2018-11-17 13:45 (UTC+0300):

> On Sat, Nov 17, 2018 at 05:36:25AM -0500, Felix Miata wrote:

>> I knew 52.9 was released upstream in June, so I kept trying June archive dates
>> and stopped when I found one containing 52.9. Upstream release bz2 that I
>> previously wgeted turned out to be dated 25 June.

> The problem is - version 52.6.0 haven't made it into the "main" that date.
> They uploaded it into the "updates/main". Yes, these are different.
> Hence the suggestion to use a later date.

> I believe I have a way to simplify things here:

> cd /var/cache/apt/archives/

> wget https://snapshot.debian.org/archive/debian/20180630T203831Z/pool/main/f/firefox-esr/firefox-esr_52.9.0esr-1_amd64.deb

> apt install ./firefox-esr_52.9.0esr-1_amd64.deb

> Note that this syntax of "apt install" does more than "dpkg -i stuff",
> dependency resolution in particular.

# apt install ./firefox-esr_52.9.0esr-1_amd64.deb
...
The following packages have unmet dependencies:
 firefox-esr : Depends: libc6 (>= 2.27) but 2.24-11+deb9u3 is to be installed
               Depends: libevent-2.1-6 (>= 2.1.8-stable) but it is not installable
               Depends: libfontconfig1 (>= 2.12.6) but 2.11.0-6.7+b1 is to be installed
               Depends: libhunspell-1.6-0 but it is not installable
               Depends: libnss3 (>= 2:3.28) but 2:3.26.2-1.1+deb9u1 is to be installed
               Depends: libvpx5 (>= 1.6.0) but it is not installable
               Depends: zlib1g (>= 1:1.2.11.dfsg) but 1:1.2.8.dfsg-5 is to be installed
E: Unable to correct problems, you have held broken packages.

Note I was able to apt install, and still have, 52.6, and still want 52.9.
-- 
Evolution as taught in public schools is religion, not science.

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/