Web lists-archives.com

Re: buster upgraded postgresql




On 11/11/18 11:52 AM, mick crane wrote:
> hello
> 
> this last upgrade buster upgraded postgresql-10 to 11
> I'm not sure what uses postgresql.
> during upgrade think there was a message about pg_upgradecluster or I
> may have read that in manpage.
> 
> :~# ps -ef | grep postgre
> postgres   599     1  0 09:36 ?        00:00:00
> /usr/lib/postgresql/10/bin/postgres -D /var/lib/postgresql/10/main -c
> config_file=/etc/postgresql/10/main/postgresql.conf
> postgres   600     1  0 09:36 ?        00:00:00
> /usr/lib/postgresql/11/bin/postgres -D /var/lib/postgresql/11/main -c
> config_file=/etc/postgresql/11/main/postgresql.conf
> 
> shows postgresql-10 and -11 both running after reboot ( I thought reboot
> might dump 10 if not needed )
> 
> should I do "pg_upgradecluster" ?
> how to find out if 10 is needed and if not needed stop it ?
> 
> please bear in mind I don't know what I'm doing.
> 
> mick

Hi Mick,

I think that you should the following:

 - drop existing cluster of PostgreSQL 11
 - upgrade existing PostgreSQL 10 cluster to 11
 - drop existing PostgreSQL 10
 - remove PostgreSQL 10 packages

You have to use commands:

pg_dropcluster
and
pg_upgradecluster

HTH

Kind regards
Georgi