Web lists-archives.com

hitch keeps crashing...




Hi Debian-users,

I'm trying to set up varnish+hitch+letsencrypt on my server,
but stubborn hitch (tls-proxy) is crashing all the time, without
saying a word:

# systemctl start hitch
# systemctl status hitch
● hitch.service - Hitch TLS unwrapping daemon
   Loaded: loaded (/lib/systemd/system/hitch.service; enabled; vendor
preset: en
   Active: inactive (dead) since Sat 2018-11-03 19:52:18 UTC; 13s ago
     Docs: https://github.com/varnish/hitch/tree/master/docs
           man:hitch(8)
  Process: 11231 ExecStart=/usr/sbin/hitch --user _hitch --group _hitch
--config
 Main PID: 11231 (code=exited, status=0/SUCCESS)

Nov 03 19:52:18 boxosix systemd[1]: Started Hitch TLS unwrapping daemon.
Nov 03 19:52:18 boxosix hitch[11231]: {core} hitch 1.4.4 starting
Nov 03 19:52:18 boxosix hitch[11231]: {core} Loading certificate pem
files (1)
Nov 03 19:52:18 boxosix hitch[11231]: {core} Daemonized as pid 11232.

# tail /var/log/messages | grep hitch
Nov  3 19:52:18 boxosix hitch: {core} hitch 1.4.4 starting

# more /etc/hitch/hitch.conf
pem-file = "/etc/letsencrypt/live/mydomain.com/hitch-bundle.pem"
frontend = "[*]:443"
backend = "[127.0.0.1]:6086"
workers = 2
daemon = on
user = "nobody"
group = "nogroup"
write-proxy-v2 = on

There is nothing more in logs. Simply starting, and... gone!
What could be reason for this? I'm completely clueless, have
no idea how to fix this. I checked hitch-website, but there
is not much, and no mailing-list to ask for help...

Jarry

-- 
_______________________________________________________________
This mailbox accepts e-mails only from selected mailing-lists!
Everything else is considered to be spam and therefore deleted.

Attachment: pEpkey.asc
Description: application/pgp-keys