Web lists-archives.com

Re: libressl in Buster?




	Hi.

On Thu, Nov 01, 2018 at 03:28:03PM +0100, Harald Dunkel wrote:
> Hi folks,
> 
> apparently the new OpenSMTPD 6.4 depends upon libressl (see
> https://www.opensmtpd.org/announces/release-6.4.0.txt), so
> I wonder what will become of #754513?
> Is there a chance to get libressl (optionally) into Buster?

Seeing that #754513 had no activity for over a year, I don't hold my
breath.


> Is there a naming conflict?

It's rather a short release cycle and a lack of feature parity with
openssl.


> Every insightful comment is highly appreciated

Portable release (opensmtpd-201801101641p1 - [1]) fails to build with
openssl on current Buster:

OpenSMTPD has been configured with the following options:
...
         Libraries: -lz -lcrypto -lssl -levent -lasr -lcrypt -lresolv

...
libressl.c: In function ‘SSL_CTX_use_certificate_chain’:
libressl.c:89:10: error: dereferencing pointer to incomplete type
‘SSL_CTX’ {aka ‘struct ssl_ctx_st’}
       ctx->default_passwd_callback,

I suspect it's trivial to patch API difference, but I don't have the
time to do so.

Reco

[1] https://www.opensmtpd.org/portable.html