Web lists-archives.com

Re: i386 version for chrome




On Saturday 27 October 2018 09:58:45 Curt wrote:

> On 2018-10-27, Gene Heskett <gheskett@xxxxxxxxxxx> wrote:
> >> These folks appear to have found some kind of workaround for the
> >> https prefixation syndrome:
> >>
> >> https://forum.vivaldi.net/topic/28038/how-to-set-a-local-file-as-ho
> >>me- page
> >>
> >> > best regards,
> >
> > Might be nice, but several of the dependecies can only be satisfied
> > if on stretch, and the curl command lines don't work on wheezy.  At
> > all.
>
> Gnomic. I searched the cited page for 'curl' and didn't find one
> reference to it; then I realized you were talking about something else
> but remain uncertain exactly what.
>
> At any rate a curl command line that proves inoperable on Wheezy
> arouses the interest of even the most jaded observer.

f you goto the vivaladi page, and look up its helpers, it gives a 
loooooong curl command to fetch them, but pasted into bash shell and 
return is pressed, you wind up with zero action and an empty prompt. A 
ctl+c gets you back your normal prompt. But thats all experimental any 
way since dpkg outputs quite a string of its own dependencies not met:

root@coyote:/home/gene/Downloads# dpkg -i 
vivaldi-stable_2.1.1337.36-1_i386.deb
Selecting previously unselected package vivaldi-stable.
(Reading database ... 517038 files and directories currently installed.)
Unpacking vivaldi-stable (from vivaldi-stable_2.1.1337.36-1_i386.deb) ...

dpkg: dependency problems prevent configuration of vivaldi-stable:
 vivaldi-stable depends on libappindicator3-1; however:
  Package libappindicator3-1 is not installed.

 vivaldi-stable depends on libc6 (>= 2.16); however:
  Version of libc6:i386 on system is 2.13-38+deb7u12.

 vivaldi-stable depends on libgtk-3-0 (>= 3.9.10); however:
  Version of libgtk-3-0:i386 on system is 3.4.2-7+deb7u1.

 vivaldi-stable depends on libpango-1.0-0 (>= 1.14.0); however:
  Package libpango-1.0-0 is not installed.

 vivaldi-stable depends on libpangocairo-1.0-0 (>= 1.14.0); however:
  Package libpangocairo-1.0-0 is not installed.

dpkg: error processing vivaldi-stable (--install):
 dependency problems - leaving unconfigured
Processing triggers for menu ...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
 vivaldi-stable

So its not going to work on a 32 bit wheezy, ever. I'll update this 
machine to a 64 bit stretch if and when the network works again. Armbian 
is now working on a rock64, but thats the only variety of nix for arm64 
that will accept and use a gateway statement in its net config and it 
took me a week to make that work. I put another drive in an older dell 
dimension and installed 64 bit stretch, but was never able to get it to 
accept a gateway statement. No errors, it just ignores it unless applied 
by hand using route. So its back on the old wheezy drive which Just 
Works(TM)  That machine isn't quite sacrificial as its the box I use to 
program the mesa fpga based CNC cards, so its needed eventually. Its 
actually got a parport! And them is scarce on new machines today. :(

Thanks Curt.

-- 
Cheers, Gene Heskett
--
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>