Web lists-archives.com

Package shared library with application




Hi All,


I'm trying to package my application together with a shared library that I have written but run now into following error:


dpkg-shlibdeps: error: no dependency information found for /usr/lib/x86_64-linux-gnu/libkImageAnnotator.so.0.0.1 (used by debian/ksnip/bin/ksnip)
Hint: check if the library actually comes from a package.


After searching for a solution, I saw that some folks suggest, as a workaround, to add following to the rules:


override_dh_shlibdeps:

     dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info


Is that a correct approach or just a hack that could cause later on problems?


Thanks in advance!


Best regards,
Damir