Web lists-archives.com

Re: No Java in Eclipse Preferences




On Wed, Oct 17, 2018 at 09:28:55PM -0500, Kent West wrote:
>    westk@westkent64:~$
>    i A eclipse-jdt - Eclipse Java Development Tools (JDT)
>    i A eclipse-pde - Eclipse Plug-in Development Environment (PDE)
>    i A eclipse-platform - Eclipse platform without development plug-ins
>    i A eclipse-platform-data - Eclipse platform without development plug-ins
>    (data)
(SNIP)
>    westk@westkent64:~$ java --version
>    openjdk 11 2018-09-25
>    OpenJDK Runtime Environment (build 11+28-Debian-3)
>    OpenJDK 64-Bit Server VM (build 11+28-Debian-3, mixed mode, sharing)
>    Any help would be appreciated.

Kent,

The Eclipse JDT package in Sid (version 3.8) came out nearly 6.5 years
ago!  I doubt it if it will work with Java 11 and I would even be
surprised if it worked with Java 8.

Sadly, Eclipse is one piece of software that I have just never been able
to find a satisfactory setup based on Debian packages.  I recommend you
download the binary tarball from upstream, untar it in /opt and work
with it from there.

Regards,

-Roberto

-- 
Roberto C. Sánchez